A short manual for TeXworks

Alain Delmotte, Stefan Löfler, and others

lowering the entry barrier to the TeX world
## Contents

1 **Introduction**  
1.1 Icons and style .............................................. 3

2 **Installation** .............................................. 5  
2.1 Under Windows ............................................... 5  
2.2 Under Linux .................................................. 6  
2.3 Under Mac OS X .............................................. 7  
2.4 Ready! ......................................................... 7

3 **First steps** ......................................................... 8  
3.1 Interface summary ........................................... 8  
3.2 Creating a document .......................................... 9  
3.2.1 Writing the document ..................................... 9  
3.2.2 Typesetting the document and viewing it ............... 10  
3.2.3 The work of \LaTeX ....................................... 11  
3.3 And when errors occur? ..................................... 12  
3.4 Changing \TeX works parameters for convenience ........ 15

4 **Going further: Editing tools** ................................ 16  
4.1 Creating a document from a template ....................... 16  
4.2 Creating a project using several source files ............ 16  
4.3 Spell-checking .................................................. 17
## Contents

4.4 Search and replace .................................................. 18  
  4.4.1 Standard functions ........................................... 18  
  4.4.2 Advanced search and replace (regular expressions) ...... 19  
4.5 Other tools for editing and error tracking ...................... 21  
  4.5.1 Standard tools .................................................. 21  
  4.5.2 Commenting .................................................... 21  
  4.5.3 Matching delimiters ........................................... 22  
  4.5.4 Smart quotes .................................................... 22  
4.6 Auto-completion .................................................... 22  
5 Going further: Other tools ........................................... 25  
  5.1 SyncTeX’ing between source and preview ...................... 25  
  5.2 Special comment strings ......................................... 25  
  5.3 Formatting the source for legibility .......................... 27  
  5.4 Showing the tags .................................................. 28  
  5.5 Organising the windows .......................................... 28  
  5.6 Cleaning the working folder .................................... 28  
  5.7 Changing the configuration ...................................... 29  
6 Advanced use: Scripting ............................................... 31  
  6.1 Introduction to Scripting ........................................ 31  
  6.2 Installing Scripts ................................................. 32  
  6.3 Using Scripts .................................................... 33  
7 Beyond this manual .................................................... 34  
A Customizing TeXworks ............................................... 36  
  A.1 Syntax highlighting ............................................. 36  
  A.2 Keyboard shortcuts .............................................. 38  
    A.2.1 Predefined shortcuts ....................................... 39  
    A.2.2 Actions listed alphabetically ............................. 41  
    A.2.3 Actions listed by menu .................................... 42  
    A.2.4 Other actions ................................................ 44  
  A.3 Roots for completion ............................................ 44  
B Regular expressions .................................................. 59  
  B.1 Introduction ..................................................... 59  
  B.2 Codes to represent special sets ................................ 60  
  B.3 Repetition ....................................................... 61  
  B.4 Alternatives and assertions .................................... 62  
  B.5 Final notes ...................................................... 63
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>C Compiling \TeXworks</td>
<td>64</td>
</tr>
<tr>
<td>Bibliography</td>
<td>66</td>
</tr>
<tr>
<td>Index</td>
<td>67</td>
</tr>
</tbody>
</table>
Introduction

Donald E. Knuth decided to create a new typesetting system, which would be called \TeX, because there had been a change in the printing system used for the volumes of his book *The Art of Computer Programming* and Knuth found the result of the new system awful.

The goal of \TeX was then to have a system which would always produce the same documents independently of the actual machine they were processed on. Knuth also designed the *Computer Modern* family of typefaces and the \METAFONT language for font description.

The work initiated in 1977 was finished (the languages were “frozen”) in 1989. \TeX and \METAFONT are not evolving any more except for minor bug fixes (\TeX versions are numbered following the decimals of $\pi$—now 3.1415926—and \METAFONT the decimals of the number “$e$”—now 2.718281).

\TeX provides basic tools (commands/instructions/“primitives”) to define typesetting; almost every detail has to be defined, but the language allows the creation of macros for repeatedly used constructs. So collections of macros are loaded through format files (i.e., pre-compiled large macro collections).

Knuth created an original default format (600 commands, more or less) which is called *Plain \TeX*. This facilitates creating documents.

The most widely used format is \LaTeX (Leslie Lamport, 1985), which provides more global commands and structures for documents (article, book,. . .) allowing easier and faster work, but sometimes with loss of flexibility due to the more or less rigid framework. But there are many other formats and \TeX-variants in use as well, such as *AMS-\TeX*, *AMS-LaTeX*, ConTeXt, or *X\TeX*, each having specific goals and advantages (and drawbacks).

To extend the format, one loads “packages” which are collections of macros specific to some aspect of typesetting.

From its specification in the late 1970s, the \TeX family had to evolve until
now, last version March 2008, to take into account the developments in the typesetting world outside \TeX. Some of the problems to answer were/are:

- taking into account other languages with “alphabets” larger than the ASCII\(^1\) one or with non-Latin characters altogether,
- having more fonts, there is not much variety in the fonts created with METAFONT (few font creators use it),
- creating documents in other formats than the normal DVI\(^2\),
- using the rich possibilities of other typesetting systems and formats like PostScript and PDF,
- having more calculation and scripting facilities,

To answer these questions and others, many “engines” and programmes have been created around \TeX, including pdftex, pdflatex, dvips, ps2pdf, and METAPOST, which opens the \TeX world to the possibilities of PostScript and PDF. X\(\TeX\) and X\LaTeX\(\) to be able to use the “normal” fonts found on the different machines and to be able to cope with writing systems different from the left to right systems which originated in Europe (Latin and Cyrillic letters and associates)—right to left, vertically, pictograms,... Or Lua\TeX\ and LuaLa\TeX\ to have a powerful scripting language.

To use \TeX\ and the systems of its family, one has to create a “source” document as \TeX\ is only a system to “transform” a source document into a (beautifully) typeset document. This source is a simple text with typesetting instructions and one needs a programme to create it: the editor.

There are many editors able to create a \TeX\ source; some are general editors, others are specifically designed for \TeX\: here \TeXworks\ comes in.

\TeXworks\ is a project to create a text editor for use with the \TeX\ family of tools; we will refer to these as (B)\TeX. Instead of creating a new sophisticated program, equipped with multiple tool-bars to meet any need, \TeXworks\ provides a simple editor, offering at first sight only a limited set of tools for text editing as well as a single button and a menu to typeset a (B)\TeX\ text.

\(^1\)“American Standard Code for Information Interchange”: a character encoding scheme including only Latin characters found in English, some common punctuation characters, and a few other symbols such as % or $ \\
\(^2\)“Device Independent”: format of files produced by \TeX
The idea to create the editor came to Jonathan Kew, the initiator and leader of the project, after a long period of reflection on the reasons why potential users tend to keep away from (L)\TeX, as well as pondering the success of the \TeXShop editor on the Mac.

Finally the goal was also to provide the same editor on many operating systems: \TeXworks currently runs on Linux, Mac OS X and Windows. The interface is always the same and the program offers the same functionality on all three platforms.

After this introduction, the second section of this manual explains how to install the software. In the third section, we describe the interface and create a first document as well as show the basics of \TeXworks. In the forth and fifth section, the advanced tools provided by \TeXworks are presented; you should read these sections only after mastering the basic working of \TeXworks. These advanced tools allow much more effective working practices. The sixth section gives a brief introduction to scripting. This section focuses on using ready-made scripts, not on writing your own scripts (which is beyond the scope of this manual and will be presented elsewhere). After that, the seventh section in which some pointers to further information about \TeXworks and sources for help are compiled concludes the main part.

Finally, the appendices provide additional information how \TeXworks can be customized, about the regular expression search/replace system, and how \TeXworks can be compiled from source. A short bibliography and an index conclude this manual.

1.1 Icons and style

Because a picture is often worth a thousand words, icons and special styling is used throughout this manual to avoid cumbersome paraphrases or mark specialties. Keyboard keys are usually depicted as \( \text{Shift} \uparrow \), with the exception of a few special keys. These are: \( \text{Shift} \uparrow \), \( \text{Page} \uparrow \), \( \text{Page} \downarrow \), \( \text{Tab} \), \( \text{Space} \), \( \text{Shift} \rightarrow \), \( \text{Page} \uparrow \), \( \text{Page} \downarrow \), \( \text{Shift} \rightarrow \), \( \text{Page} \uparrow \), \( \text{Page} \downarrow \), \( \text{Backspace} \), and \( \text{Tab} \).

In addition, mouse clicks are depicted as \( \text{Left click} \) and \( \text{Right click} \) (left click) and \( \text{Right click} \) (right click; on Mac OS X with a one-button mouse, this is usually available by holding down \( \text{Ctrl} \) while clicking).

Apart from input instructions, several passages throughout this manual are marked by special styling.
Information that is only valid or relevant for a particular operating system is marked like this:

This only concerns you if you use Windows.
Of course you can also read it if you use another operating system.
It just will not be of much use to you.

Code examples are set in a fixed-space, typewriter font, with lines above and below to set it apart from the rest of the text:

\begin{verbatim}
Hello \TeX-World!
\end{verbatim}

Closely related to this, chapter 3 contains several tutorials, which are typeset just like the code examples above, but with an additional notebook icon next to it.
\texttt{TEXworks} is only a text editor; to be able to create documents with (B)\TeX and to typeset them to PDF, we also need what is called a \textit{\TeX distribution}. This is a collection of programs and other files which will be automatically called by \TeXworks during its work. Thus, you need to install a distribution: we will do that \textit{before} starting \TeXworks for the first time, as this way, \TeXworks will automatically find what it needs.

\textbf{\TeX Live} (http://www.tug.org/texlive/), a combination of \texttt{teTeX}, \texttt{MacTeX} and \texttt{XEmTeX}, is available for all three operating systems (Linux, Mac OS X, Windows). The current version is \TeX Live 2010. Note that you need a reasonably recent version of \TeX Live (2008 or later at the time of writing) to use all features of \TeXworks.

For Linux: most Linux distributions include a \TeX distribution, but it may not be installed by default and you will have to use the Linux package management tools to do that. As an alternative to \TeX Live, one can use \texttt{teTeX} (http://www.tug.org/teTeX/), a predecessor system to \TeX Live.

For the Mac: \texttt{MacTeX}, a new distribution based on gw\TeX and Xe\TeX, is available; see http://www.tug.org/mactex/.

For Windows: a very popular distribution is \texttt{MiKTeX} (http://www.miktex.org/). \texttt{MiKTeX} has an update programme, which has also been ported to Linux. You can also use the \texttt{XEmTeX} distribution (http://www.xemtex.org/).

\section*{2.1 Under Windows}

Most of the larger \TeX distributions already contain \TeXworks as a package. Sometimes, these versions even have some distribution-specific enhancements.
2. Installation

So, the preferred way of installing \TeXworks on Windows is to use the package manager of your distribution. In this case, you can skip the next few paragraphs. Be sure to read the end of this section, though, as it provides important information about customizing \TeXworks to your needs.

If you want to obtain an “official” version, obtain \TeXworks by downloading the setup from the \TeXworks web site http://tug.org/texworks/ after the installation of the \TeX distribution.

Simply install \TeXworks by running the setup file. During the installation, you will be asked where to install the program, if you want to create shortcuts, and if you want to always open .tex files with \TeXworks. There are reasonable default values that should work well for most users.

If you want full control over how and where \TeXworks is put, you can also download the .zip archive from the website and unpack it wherever you like. Note that in this case, shortcuts and file associations must be created manually.

When you start \TeXworks for the first time, it creates a folder named TeXworks in your home folder\(^1\). This folder will contain some sub-folders for auto-completion, configuration, dictionaries, templates, and interface translation/localisation files—we will see these in more detail later.\(^2\)

NB. At the time of writing, if <your name> contains any non-ASCII characters (for example accented characters), some functions of \TeXworks may not work correctly. For example, the spell-checker and forward/reverse synchronization between the source and .pdf will be impaired.

2.2 Under Linux

Several common Linux distributions already have packages for \TeXworks. They are adequate for most users and facilitate installing \TeXworks considerably.

If your Linux distribution does not provide recent, adequate packages, you need to build \TeXworks from source yourself, which is fairly easy on Linux. After the installation of the \TeX distribution, go to http://code.google.com/p/texworks/wiki/Building and follow the instructions suitable for your Linux distributions. Also see section C.

Once the program is installed, start \TeXworks. The folders .TeXworks and .config/TUG will be created in your home directory.

\(^1\)on Windows XP, your home folder is C:\Documents and Settings\<your name>. On Windows Vista/7, your home folder is C:\Users\<your name>.

\(^2\)\TeXworks will save its preferences in the registry: \%HKEY_USERS\S-...\Software\TUG\TeXworks. If this is erased, it will be recreated with default values at the next use.
2. Installation

2.3 Under Mac OS X

MacTeX 2010 already contains \TeXworks as a package. So, the preferred way of installing \TeXworks on the Mac is to use the package manager of your distribution. In this case, you can skip the next few paragraphs. Be sure to read the end of this section, though, as it provides important information about customizing \TeXworks to your needs.

If you want to obtain an “official” version, obtain \TeXworks by downloading the archive from the \TeXworks web site \url{http://tug.org/texworks/} after the installation of the \TeX distribution.

You need to get \TeXworks-Mac-0.3r567.zip\(^3\) which contains everything you need.

It is a standalone .\app package that does not require any Qt files installed into /Library/Frameworks, or other libraries into /usr/local/lib. Just copy the .\app anywhere you like and run it.

On Mac OS X, the \TeXworks resource folder will be created in your Library folder (~/Library/TeXworks/), inside your home directory. Preferences are stored in ~/Library/Preferences/org.tug.TexWorks.plist which you can delete if you ever suspect it is causing problems.

2.4 Ready!

Finally, some files may need to be added to the “personal” files that \TeXworks creates. As the exact location of these depends on your platform, this will be referred to as <resources> or the \TeXworks resource folder throughout this manual. On Linux, this is ~/.TeXworks, on Windows XP it is C:\Documents and Settings\<your name>\TeXworks, on Windows Vista/7 it is C:\Users\<your name>\TeXworks, and on Mac OS X it is ~/Library/TeXworks/ by default. The easiest way to locate this folder in recent versions of \TeXworks is to use the Help→Settings and Resources... menu item. It opens a dialog which shows you where \TeXworks saves its settings and where it looks for resources.

After installation and first run, have a look in the sub-folders of the \TeXworks resource folder and delete any qt_temp.xxxx files; they are temporary files left behind and could interfere with the normal ones, which are installed in the same folder, later on.

\(^3\)Version at the time of writing this manual.
First steps

Let’s now see how to create a first document: for this you’ll need to type some text in the editor window of \TeXworks. (\LaTeX is not WYSIWYG\textsuperscript{1} software, so you’ll have to type the text and the instructions for formatting it and you’ll see the result only after “typesetting” the text. This looks a little bit dry, but one very quickly gets used to it and it is well worth the effort.

3.1 Interface summary

When one opens the editor, it shows a very sparse interface: a title bar, a menu bar, two small toolbars, a large typing zone (white) and, at the bottom, a status bar. We are in the source/editor window. If you have already typeset the document previously, the resulting .pdf will be shown on the right hand side in the preview window.

The first toolbar has a button to typeset and an drop-down menu to choose the format for typesetting (we’ll choose pdfLaTeX). Knowing that the keyboard shortcut for typesetting is Ctrl T (Mac OS X: ⌘ T) and that we almost never change the format, we could even hide this toolbar. The selection of a format for compiling can also be changed through the Typeset menu.

The second toolbar provides the standard functions: New document, Open, Save | Undo, Redo | Cut, Copy, Paste | Search, Replace.

\textsuperscript{1} What You See Is What You Get.
Even though they are not looking like real buttons, the widgets in the status bar can be clicked. The widgets showing the current position (line or page, respectively), for example, open a dialog to enter a line or page to jump to when clicked. The other widgets typically open contextual menus where some settings can be changed.

### 3.2 Creating a document

3.2.1 Writing the document

As an example of the use of T\textTeX{}works, we will work with L\textTeX, but any other \textTeX{} system is possible. In particular, if you need to use some special fonts\footnote{You can only use fonts (L\textTeX{} knows, most of which are coming in packages included in your distribution. You cannot use your “normal” fonts, unfortunately. For more information, see for example http://faq.tug.org/ and http://www.tug.dk/FontCatalogue/\textemdash\textemdash the X\textLaTeX{} system is very powerful.\footnote{See the bibliography for pointers to X\textLaTeX{} and X\textLaTeX}.}—a mandatory font for an official template, non-Latin alphabets, etc.—the X\textLaTeX{} system is very powerful.\footnote{See the bibliography for pointers to X\textLaTeX{} and X\textLaTeX.}
3. First steps

Let’s create our first document now. Enter the following text exactly as shown. To show some of the features of TeXworks/\LaTeX, it is in French intentionally.

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{geometry}
\geometry{a4paper}
\usepackage[frenchb]{babel}
\title{Premier document}
\author{Un TeXnicien}
\date{}
\begin{document}
\maketitle
Voici un texte accentué en français!
\end{document}

Save the file in a folder for test documents (e.g., <home>\TeXworks_tests); call the file first.tex. Note that it should have a .tex extension.

3.2.2 Typesetting the document and viewing it

Next we start typesetting\(^4\) by clicking the green button \(\) or by \(\text{Ctrl} \) (Mac OS X: \(\) ).

A new panel opens between the typing area and the status bar: the output panel, labeled Log; everything \LaTeX{} is doing is displayed there\(^5\). When \LaTeX{} finishes this panel disappears (if there no error occurred) and a new window will appear; in this new window, the Preview window, you can see a page with a title “Premier document” followed by the name of the author “Un TeXnicien”, both centred, the text “Voici un texte accentué en français!”, and a page number at the bottom centre.

\(^4\)We also use the words “compilation” and “to compile” for the same action; indeed \LaTeX{} works on the source file to produce a .pdf output, so there is a compilation.

\(^5\)see page 12 for a picture of the panel
Notice that the mouse cursor is like a magnifier in the new window. If you press (and hold) the left button of the mouse you can see the text under the magnifier much bigger (it is a magnifier, isn’t it!); you can move the magnifier and so inspect the text in detail.

To go back to the source, you can just click in its window or better use \( \text{Ctrl}\) + \( \text{E} \) (Mac OS X \( \text{F4}\) + \( \text{E} \)). This shortcut toggles between the two windows. See also section 5.1 to automatically move to a specific location in the output from the source or vice versa.

### 3.2.3 The work of \LaTeX

Let’s shortly analyse the result to understand what \LaTeX{} did and why, now. Introductions and full tutorials can be found on the internet: see for example *lshort* which should be installed as part of your \TeX{} distribution, and is also available from CTAN.

First, we ask to create a document of the `article` class: this defines the global layout of the document.

Next, we say that the input document (the source) is saved with the Unicode encoding `utf-8` and that it may contain characters which are not present in the standard ASCII without accents. We also want to use an output encoding T1 (the modern \TeX{} encoding); we also want an A4 document and not the default US letter size. Finally, we make it clear that the typography should follow the French rules using the `babel` package. Those general instructions for the work are done by packages called with options.

Lastly, we finish the declaration part of the document, the `preamble`, giving the title, the author, and the date of the document; here we specify no date.

Next comes the body of the document, which describes the actual content, between the lines `\begin{document}` and `\end{document}` (these are \TeX{} commands).

Let’s do some experiments to show the effect of these instructions. For this, we put a `%` in front of the instructions; the `%` and everything after it will be considered as comment, which will be ignored by \LaTeX{}.

Comment out the line `\usepackage[utf8]{inputenc}`, and typeset the file. You should see that the accented characters are now displayed incorrectly.

---

6 *The (Not So) Short Introduction to \LaTeX{} 2e*

7 *Comprehensive \TeX{} Archives Network*, a network of mirror servers of the central CTAN; there, one can find almost everything about \TeX, \LaTeX{}, and more: [http://www.ctan.org](http://www.ctan.org)

8 This influences, e.g., automatic hyphenation of words or the way punctuation characters are typeset

9 Notice that the comments are, by default (this can be changed), coloured red by \TeX{}works, so we see them well.
in the preview window. If, in addition, you also comment out the line \usepackage[frenchb]{babel}, \LaTeX{} will give an error. Just hit \rightarrow to continue the typesetting.

After these experiments, let’s modify the text as follows:

\begin{document}
\maketitle
\tableofcontents

\section{Petite démonstration}

Voici un texte accentué en français!
Suite du texte entré après avoir fait un retour chariot. Dans l’éditeur on peut demander un passage automatique à la ligne du texte saisi; mais le numéro de ligne n’est incrémenté que par un retour chariot.

Nouvelle ligne en passant une ligne dans la source: c’est la manière d’indiquer un changement de paragraphe.

\end{document}

Redo the previous experiments and observe the changes which appear.

Note that entering only one carriage return doesn’t create a new paragraph. In \LaTeX{}, one has to have an empty line for that. In \TeX{}works, the line number of the source (on the right in the status bar) numbers the lines created with carriage return, not the wrapped lines.

3.3 And when errors occur?

When you create a document for typesetting with \LaTeX{}, you cannot avoid making mistakes: forgetting a closing brace or an \end{} to close an environment, using mathematical commands without switching to mathematical mode, etc. When you compile and there is an error, \LaTeX{} stops, giving you a chance to deal with the problem. This is shown by the stopping of the scrolling action in the output panel, and an error message being displayed, with \LaTeX{} waiting for an instruction to know what it should do.
One sees the *typing cursor* in the line between the output panel and the status bar: the *console bar*.

The error message is on many lines, for example like this:

```latex
! Undefined control sequence.
1.168 ... fermante ou d'une commande \web
+\end{+}+ de fermeture d'un...
?
```

\LaTeX{} says that it doesn’t recognize the command name, sometimes suggests to see the manual or to type `h` (plus → ↩) for help, points to the line number where it noticed the error\(^\text{10}\) (here 168), and shows the place of the error at the cut of the line (here at `\web`). Finally, it shows that it waits for an action from us by displaying a single question mark.

There are different possible actions:

- Type → ↩ and ask to continue as if nothing happened; sometimes this allows to finish compiling, but there will be an error in the result.
- Type h → ↩ to ask for help; this help is not always clearer than the error message, but often gives a clue.
- Type i → ↩ to tell \TeX{} that we will propose a replacement text. Enter the text followed by → ↩; it will be used, beginning at the start of the error, but you should correct the source afterwards as \TeX{} never changes that.

\(^\text{10}\) Unfortunately, this does not always have to be the place where the actual mistake was made in the sources. This is discussed later.
• Type `x` to stop compilation. This is the traditional (L\TeX) way to kill a typesetting process.

We can also kill the typesetting by repeating the action used to start it: the green typesetting button will have changed to a red one with a white cross \(\times\). By clicking on that button or by hitting `Ctrl`, `T` (Mac OS X: `⌘`, `T`) again, the \LaTeX process is terminated. The output panel is still visible and so one can still see the error message.

You should note that sometimes an error appears far from its actual position. For example, when opening an environment but not closing it, \LaTeX doesn’t see the error before it encounters another end of environment without closing of the first one. The error is often only picked up at the `\end{document}` command, which shows that another environment was not closed!

Sometimes, an error still occurs during subsequent runs of (L\TeX) even after it was corrected in the document. This can happen because (L\TeX) creates a number of intermediary files which can still contain the original, erroneous code. Therefore, it is advisable to remove those files after fixing an error. \TeXworks provides a command to facilitate this—see section 5.6.

After an error occurred, the output panel remains open—even after consecutive typesetting runs—to help you fix the problem (which can sometimes take several attempts and restarts of (L\TeX)). Once all problems are solved, you can close the panel by the `Windows→Hide Output Panel` menu item. As an alternative, you can also configure to output panel to hide automatically as soon as the typesetting process finishes successfully by setting `Edit→Preferences...→Typesetting→Hide output panel` to `On success`. Since one can easily overlook other problems in the document (e.g., undefined references) that do not cause (L\TeX) to fail, this option is only recommended to expert users.

To help you in finding and fixing error (at least if you are using \LaTeX), \TeXworks comes with a small script that extracts all errors, warnings, and other noteworthy messages from the console output and presents them to you in a simple, tabular form.
Here, you see a list of \LaTeX{} messages, color-coded and sorted by severity. Red represents errors, yellow indicates warnings, and blue stands for over- and underfull box warnings. Next to the colour bar, you see the name of the file in which the error was detected. Next to that, you see the line number (if the script was able to determine that), as well as an excerpt from the console output telling you what the error was. Moreover, the filename is a link which will take you to the file (and, if a line number could be determined, also the line) where \LaTeX{} reported the error. Hopefully, you can quickly fix any errors that may occur this way.

In case you are not using \LaTeX{}, this script may be of little use, particularly if the console output is formatted differently. In this case, you can simply disable the error parsing hook script (see section 6.2).

### 3.4 Changing \TeX{}works parameters for convenience

If the default font of the editor doesn’t suit you, it is possible to change it from Format → **Font**... by selecting a new one in the dialogue box which appears. This change will apply only to the current window, and until \TeX{}works is restarted.

From the **Typeset** menu or from the drop-down on the **Typesetting tool bar**, you can change the compilation format. Again this change will only be temporary and for the current document.

To have permanent changes, you need to change the preferences through the Edit→**Preferences**... menu item, using the Editor tab for the font and the **Typesetting** tab for the compilation format: the default format is at the bottom of the tab.
When you have had some practice with TeXworks, you’ll find the need for more effective tools. Many of them are bundled with TeXworks. We are going to see some of them now.

4.1 Creating a document from a template

Most documents you will create will use the same instructions in the preamble, the same layout settings, similar heading and so on. You can use predefined templates to get started quickly or create your own with all of these settings already in place.

Use File→New from template... or Ctrl+Shift+N (Mac OS X: ⇧ Shift ▲ N). A dialogue box opens to allow you to select one of the templates. After selecting one and pressing OK, a document is created and you can start to work.

If you want to create a personal template, you just have to create a suitable document with everything you always want to do (and perhaps marking places to fill in the rest) and save it as a .tex file in the <resources>\templates folder, or a sub-folder of it, if you wish.

4.2 Creating a project using several source files

When the source becomes long, it is sometimes difficult to navigate and maintain it. In that case, it is useful to split the source into different smaller files: one file will be the main document, with the preamble and the document
environment, as well as calls to the “sub-documents”\(^1\), which could in turn contain separate chapters, for example.

But there might be a problem if you want to start typesetting/compilation in a sub-document: as there is neither a preamble nor a document environment there, \LaTeX{} will stop immediately with an error.

To tell \TeXworks{} that it should typeset the main document, one adds at the very beginning of the sub-document the instruction:

\begin{verbatim}
% !TeX root = path/main_file.tex
\end{verbatim}

for example:

\begin{verbatim}
% !TeX root = manual.tex
\end{verbatim}

If the main file is in the same folder, its name is enough, as in the above example. Otherwise, you must also give the path to the main document (preferably relative to the sub-document in question, e.g., ..//manual.tex). Notice that the slash / and not the backslash \ should be used as directory separator even on Windows.

Further, with MiKTeX, the call to a sub-document \input{name.tex} should include the extension .\texttt{tex} to ensure proper SyncTeX functionality (see section 5.1).

### 4.3 Spell-checking

You can turn on automatic spell-checking of your source document from Edit → Spelling → <language>. It is also possible to ask \TeXworks{} to enable spell-checking by default by setting a dictionary in Edit → Preferences… → Editor → Spell-check language.

During typing, every word the spell-checker considers wrong is underlined by a red wavy line. A right-click on the word opens a contextual menu in which there are some replacement suggestions. Click on the desired word to make the replacement.

Before using the spell-checker, you need to install dictionaries in the right folder of \TeXworks: <resources>\dictionaries. The <resources> folder can be accessed easily via Help → Settings and Resources….

\(^1\)Called by the commands \texttt{\input{}} or \texttt{\include{}}, see \LaTeX{} manuals for more information.
On Linux, the dictionaries are usually taken from the folder `/usr/share/myspell/dicts`—the default path for myspell dictionaries. Note, though, that the maintainer of your TeXworks package may have changed this to reflect the file system layout of your Linux distribution. You can override this default by setting the `TW_DICPATH` environment variable before running TeXworks.

One can use the available dictionaries for OpenOffice.org and other free software; if you have Mozilla Thunderbird with spell-checking, you can copy its `.aff` and `.dic` files as well, for example.

### 4.4 Search and replace

#### 4.4.1 Standard functions

The options of the menu *Search—Find…, Find again, Replace…, Replace again, and Go to Line…* (Ctrl F, Ctrl G, Ctrl R, Ctrl Shift R, and Ctrl L, respectively)—are standard actions (Mac OS X: F, G, R, Shift R, and L, respectively)—are standard actions; the first and the third open a dialogue box:

Here, the usual options are available: *Wrap around, Find backwards, Search/Replace within selection, or Find all occurrences.* The following options are also usual: *Case sensitive and Whole words.* By default, the search is forward, towards the end of the document.

The option *Search/Replace in all open files* is also a frequent choice, but not as much as the others; this allows, for example, replacement in all the files of a project—pay attention, though, as this is very powerful.

The last option, *Regular expression*, is detailed in the next sub-section.

In the *Search* menu there are other options:

---

See, for example, [http://extensions.services.openoffice.org/dictionary](http://extensions.services.openoffice.org/dictionary). The `.oxt` files can be renamed to `.zip` and then uncompressed to find the required `.dic` and `.aff` files.
Copy to Find copies the currently selected text into the Find field of the Find dialogue or the Replace field of the Replace dialogue; you still need to open the dialogues separately.

Copy to Replace copies the currently selected text into the With field of the Replace dialogue.

Find Selection uses the current selection for a search without opening the Find dialogue—very fast.

Show selection scrolls the view to the currently selected text—useful if word wrapping is turned off and you moved in the document using the vertical scroll bar on the right.

4.4.2 Advanced search and replace (regular expressions)

The regular expressions provide a very powerful tool, but they require some effort to be well understood. To understand them fully would require a manual of its own, so we’ll only give some simple ideas of use. For more advanced uses, as well as lists of the most used codes, see section B.

Suppose we have the following text:

Voici du texte pour tester les expressions régulières dans du texte accentué.
Voici du texte pour tester les expressions régulières dans du texte accentué.
Voici du texte pour tester les expressions régulières. Voici du texte pour tester les expressions régulières.
truc truc
tél.: 010-99-99-99
tél.: 00.32.10.99.99.99
tél.: 00/32-10/99.99.99

We want to

1. insert an empty line after each “accentué” (to create paragraphs in \LaTeX{}), but not after the three telephone numbers;

2. replace each tab character between the two words “truc” of the fourth paragraph by three spaces; and finally

\textsuperscript{3}Such manuals exist on the internet.
3. make the telephone numbers consistent by replacing the various punctuation characters by spaces.

For 1., in the dialogue box **Replace** (Ctrl+R) for **Replace**: we put \n\n\n4 and in **With**: \n\n\n. \n\n is the code to match or insert a line feed. You will need to select the first four paragraphs and the beginning of the fifth (the first telephone number) and to tick the **Replace within selection** and **Regular expression** options; if this was not done and an empty line has been inserted after each line, select the telephone lines and do the reverse action: replace \n\n\n by \n\n. So we replaced one line feed by two, creating an empty line.

For 2., use \t and \t\t5. \t is the code which represents a tab, while a space is typed in literally (here represented as \t).

For 3., find \-|\.|/ and replace with \/. Here, \- provides alternatives (-, ., or /); for the dot we have used \. because the dot alone is a regular expression code which represents any character and we would have replaced all the characters by spaces! We therefore have to use a code—prefixing the dot with a backslash tells specifies that the normal meaning of the dot should be used instead of the special meaning it usually has in regular expressions.

If one has strings of the same character but of different lengths (for example 3, 4, or 5 times the same character e) and one wants to truncate all these strings to a string with less characters (for example 2), one can ask to replace the string \e{3,5} by \ee.

If one wants to insert the same string at the beginning of some paragraphs separated or not by an empty line, for example \noindent or \item, one can replace \n\n or \n by \n\n or \n\n\n\noindent or \n\noindent. Pay attention, we have a double \ in front of \noindent to get one (\noindent) because \ is an escape character in regular expressions (we’ve met it before in the expression \.)!

If it were making sense, we could replace all the letters between “a” and “m” by “$” using \[a-m]* and \$.

4 the \ are used here only to show the limits of the entered text and they should not actually be entered.

5 These are three space characters.
4. Going further: Editing tools

4.5 Other tools for editing and error tracking

4.5.1 Standard tools

It is always possible to undo an action using Edit→Undo or $\text{Ctrl} \text{Z}$ (Mac OS X: $\text{⌘Z}$): this way you can undo stepwise! The inverse action, redo, is available as Edit→Redo or $\text{Ctrl} \text{Shift⇑Z}$ (Mac OS X: $\text{⌘Shift⇑Z}$).

Texworks also provides the standard editing tools such as the clipboard; therefore one can select, cut/copy and paste a piece of text normally. You can select with the mouse by dragging over the desired text, or by double-clicking to select a word. Using the keyboard, holding down $\text{Shift⇑}$ while moving using the arrow keys will select text. You can also move and select word by word moving left or right holding $\text{Ctrl} \text{Shift⇑}$ down ($\text{⌘Shift⇑}$ on Mac OS X). The clipboard shortcuts are the ones you’ll find in almost every program: $\text{Ctrl} \text{X}$ to cut, $\text{Ctrl} \text{C}$ to copy, and $\text{Ctrl} \text{V}$ to paste ($\text{X}, \text{C}$ and $\text{V}$, respectively, on Mac OS X).

You can easily change the case of a selection—put everything upper case or lower case—using Edit→Change case and next, depending on the desired effect, ALL UPPERCASE, all lowercase, or Toggle Case (which toggles the case of each letter individually).

It is also convenient to show the line numbers, as all error messages refer to these numbers; you can toggle the line numbers, on the left of the editing panel, from Format→Line Numbers.

4.5.2 Commenting

When preparing a document with (I)TeX, it is often useful to prevent compilation of a portion of text to be able to locate an error; you can do this piece by piece until you find the part which causes the error. For that, commenting the source block by block is needed.

We have seen that the symbol % marks the beginning of a comment. To comment a big piece of text, it is sufficient to select it and ask to mark it as comment Format→Comment or $\text{Ctrl} \text{Shift⇑} \text{I}$ (Mac OS X: $\text{⌘Shift⇑I}$). To remove the comment, select the lines and choose Format→Uncomment or $\text{Ctrl} \text{Shift⇑} \text{I}$ (Mac OS X: $\text{⌘Shift⇑I}$).

---

6 $\text{Ctrl} \text{Y}$ and $\text{Alt} \text{Shift⇑Backspace}$ work as well on Windows. $\text{⌘Y}$ work as well on Mac OS X.
4. Going further: Editing tools

4.5.3 Matching delimiters

A frequent error is to forget a closing symbol: parenthesis, bracket, square bracket, etc. \TeXworks helps with a tool to show the pairs of symbols: when the cursor moves over one of these symbols, its partner is briefly highlighted. You can also select an entire block using Edit→Balance Delimiters or by the shortcut \[\text{Ctrl} \ B\] (Mac OS X: \[\text{F} \ E\]). Thus, you will immediately see the scope of the block.

4.5.4 Smart quotes

Another similar error, but this time semantic and not hindering typesetting, is in the use of quotes when one wants to give focus to some text.

There are two types of quotation marks in English: the ‘single’ quotes and the “double” quotes. They are formed by ‘ and ’; these are not the quotation marks used in programming and found on the keyboard: " and ". Using the \TeXworks smart quotes system, one can use the latter as normal to automatically produce the typographically correct single/double opening and close quotes.

In a .tex document, select one of the smart quotes system: Format→Smart Quotes→\TeX Ligatures, →\TeX Commands, →Unicode Characters. Then, when you want to start a quoted section in your text, let’s say enclosed in double quotes, type ", then the text to be quoted, and finish again by "; \TeXworks will automatically insert the correct opening quotes \`\` and later the correct closing ones ". The three options give the same result in the typeset document, but \TeX Ligatures should work best in most cases.

Finally, it is possible to define personal quotation marks systems (in the file smart-quotes-modes.txt in the configuration folder of the resource folder).

4.6 Auto-completion

Another tool which rapidly becomes indispensable is auto-completion. Indeed, when you use (b)\TeX, you have to continuously enter codes to, for example, create environments; you also have to remember to close every group you open.

\[\text{On some keyboards, like the French one, it is impossible to use \text{[Ctrl} \ Shift \ F\] or \text{[Ctrl} \ Shift \ F\]; these shortcuts can be changed, however—see section A.2} \]
Auto-completion allows you to type a keyword, hit the key, and have \TeXwork inserts the \LaTeX\ command or environment code automatically.

As an example to insert \LaTeX, we have to type \LaTeX. This is not difficult, but entering “\” followed by the word “\LaTeX” with alternating capitals and lower case letters could become annoying after a while. With auto-completion, you just enter \texttt{latex} and hit \lvertvert to get \LaTeX. You just have to take care that there is no letter directly preceding or succeeding \texttt{latex—e.g., alatex—, or else the mechanism might not pick up the correct keyword.

Another example is \texttt{bmin}, which gives

\begin{verbatim}
\begin{minipage}{}
•
\end{minipage}•
\end{verbatim}

with the cursor between the empty pair of curly brackets where you need to enter the size of the minipage. See the section A.3 for a list of the keywords for auto-completion. Notice the “•” in the minipage environment. They are placeholders which can be reached by \texttt{Ctrl} \lvert\rvert (\texttt{Shift} \lvert\rvert on the Mac), repeating this shortcut cycles forward through the placeholders; by \texttt{Ctrl} \texttt{Shift} \lvert\rvert \lvert\rvert (\texttt{Shift} \texttt{Shift} \lvert\rvert \lvert\rvert), you can also cycle backwards.

If a partial keyword is given, repeatedly hitting \lvert\rvert will cycle through possible completions. For example, \texttt{bali} (the \texttt{b} commonly indicates the beginning of an environment, \texttt{\begin{figure}}) creates the \texttt{align} environment after one \lvert\rvert, next \texttt{align*}, and after that, in succession, \texttt{alignat}, \texttt{alignat*}, \texttt{aligned}, \texttt{alignedat}, and \texttt{alignedat} with options; to access the last environments directly, they have their own codes which start by \texttt{bali} (\texttt{balis}, \texttt{baliat}, \texttt{baliats}, \texttt{balied}, \texttt{baliedat} and \texttt{baliedato}).

If you want to create your own keywords, you can add a .\texttt{txt} file in the completion folder inside the resources folder. The entries in the file should have the following format:

\begin{verbatim}
bfigo:=\begin{figure}[#INS#]\end{figure}•
\bibliography{#INS#}•
\end{verbatim}

In the first case, \texttt{bfigo} is the assigned keyword (with :=) to be converted into a \texttt{figure} environment with an optional argument; there are two carriage returns (#\texttt{RET}#) after the \texttt{begin}, i.e., an empty line, and the cursor is placed

\footnote{In particular with keyboard layouts where \texttt{\} is not directly accessible.}
between the square brackets (at the position of #INS#). “•” is a place holder as introduced before.

In the second case, we give ourselves a shortcut, which will let us type the first part of \bibliography{} and have \TeXworks convert it to the full name plus braces (with the cursor between them). In this case, the keyword is the instruction itself.

Note that the .txt file containing the auto-completion information needs to be UTF-8 encoded—which is the default encoding for all files created with \TeXworks.
5.1 SyncTeX’ing between source and preview

When you are reading a document in the preview window and see something to change, it is convenient to go immediately to the corresponding place in the source. To do so, hold down ⌘ (Mac OS X: ⌘) and click at the appropriate place in the preview; the cursor will move and highlight the corresponding location in the source window. The same is true in the other direction: ⌘ in the source will highlight the same line in the preview window.¹

Here a remark for users under Windows: this only works if all the names for folders/files/… do not have accented characters. If, for example, your document is in C:\Documents and Settings\Propriétaire\My Documents\thesis it will not work because of the é in Propriétaire!

5.2 Special comment strings

Special comments, at the very beginning of the files, can be used to manage two other aspects of the compilation.

By default, TeXworks uses the “utf-8” encoding for loading and saving files, but some files could be saved in another encoding. Common ones are “latin1”, which is the dominant encoding on Windows when using western languages, and “Apple Roman” which is dominant on Mac OS.

¹It is also possible to use a right-click (✓) to open a context window and select “jump to PDF” or “jump to source”.

25
To set a different encoding for a specific file one can put the following at the beginning of that file:

```
% !TeX encoding = latin1
```

Note that without this line, you must tell \TeX\ works the correct encoding manually. Otherwise, your data could be corrupted! To override \TeX\work's default choice of encoding, use the menu that appears when you click on the editor window’s middle status bar widget.

If you opened a file in \TeX\works that was not saved as utf-8 but is lacking the `% !TeX encoding` line, it might be displayed with (some) weird characters. In that case, you can specify the correct encoding via the status bar widget menu in the same way, but it is imperative that you then use **Reload using selected encoding** from the same menu! This forces \TeX\works to open the document again with the encoding you selected, the weird characters should be replaced by normal ones, and only then it is safe to continue to work normally. To avoid having to repeat this procedure each time you open this file, you should either switch to utf-8 for saving it in the future or add a proper `% !TeX encoding` line.

If we want to compile a file with another programme than the default \TeX\ or \LaTeX, we put at the beginning of the file:

```
% !TeX program = <the_programme>
```

for example:

```
% !TeX program = xelatex
```

Pay attention to this last instruction. You have to use the name of the programme here which should be used for the whole project, as the first encountered programme when starting typesetting is used (which is the one from the sub-document you are in). \TeX\works will use that programme, even if another name appears in the main document!

When opening a document which contains a `% !TeX program` line, the specified programme will become the one to use and its name will appear in the drop down menu in the toolbar; you can, however, override this by selecting a different one from the drop down list, if you want.
5. Going further: Other tools

In addition, you can set the spell checking language by a similar comment line:

\% !TeX spellcheck = <language_code>

The language codes available on your system are listed in parentheses in Edit→Spelling next to the human-readable name of the language.

5.3 Formatting the source for legibility

To facilitate legibility of the source, one can use indentation as programmers do:

\begin{itemize}
  \item First element of the list;
  \item second element;
  \item last element:
    \begin{itemize}
      \item first sub-element;
      \item second sub-element.
    \end{itemize}
\end{itemize}

This increases legibility, but works well only on short lines, without text wrapping; or if one chooses not to use text wrapping by unchecking Format→Wrap lines.

The command Format→Indent or the shortcut \texttt{Ctrl} [Mac OS X: \texttt{F} [ ] ] will indent the line, or the selected lines, by inserting a tab character. You can repeat the process to increase the indent.

To remove one level of indentation, use Format→Unindent or the shortcut \texttt{Ctrl} [Mac OS X: \texttt{F} [ ] ] .

As indent only indents the first part of very long (wrapped) lines, this is not very satisfactory in some cases. But one can ask \TeX works to split a long line (longer than the width of the editing window) into short ones adding a hard coded line feed. Format→Hard Wrap... opens a dialog box in which you can specify the width of the lines; you can also re-format lines which have already been split.

\footnote{See the modified shortcuts if your keyboard layout does not allow these actions.}
5.4 Showing the tags

When a document is becoming long and you want to move to a specific place (a chapter, a section, a subsection, ...) you normally need to scroll the editing window to find the desired location, or use the Find dialog if you remember a keyword in the chapter’s title.

To the same end, though a lot more comfortable, you can also use the structural information in the document to navigate the source: the menu item Window → Show → Tags opens a panel showing the information detected by \TeX\ works. Clicking on an item in the panel moves the cursor to the corresponding part in the source. That panel, like any other, can be resized by dragging its border.

The same action is possible in the PDF window from Window → Show → Table of contents, but this only works if one has created structure tags in the PDF file using the package hyperref.

5.5 Organising the windows

By default, the editor/source window opens on the left and the preview one on the right (when the corresponding PDF file exists), thus splitting the screen in two.

You can change the position of the windows in the Window menu. → Stack and → Side by side give the default effect if there is only one document open. If not, → Stack creates a mosaic with all the windows. The other options allow to place the windows for your convenience. It is also always possible to resize and move the windows manually, of course.

For the preview you can change the way it is presented and of course the zoom by View → Actual size, → Fit to width and → Fit to window; you can also zoom in and out. Shortcuts exist for all these actions and are shown next to the menu items.

5.6 Cleaning the working folder

Very soon when one uses (L)\TeX, one discovers that the working folder is cluttered by many files which have the name of the source file but different extensions: .aux, .log, .toc, .lof, .lot, .bbl, ...

All these are files needed by (L)\TeX to be able to create the table of contents, lists of figures/tables, the bibliography, the cross references and, also very importantly, to keep track of what it did (in the .log file).
Apart from the external files, images, pictures, ..., the only files required are the \texttt{.tex} files, the sources of the document. One can erase all the others. Sometimes, this is even necessary when (\LaTeX) \TeX gets stuck after an error.

This can be done using a \TeXworks command from the \textit{File} menu with the \texttt{→ Remove Aux files...} item.

When you use this command, a dialog box opens in which you can check/uncheck the files you want to remove. The dialog box will only list files that actually exist in the folder; if you removed all these auxiliary files before, you get a message box saying that there is no file to remove at the moment.

The list of auxiliary files which are taken into account is defined in the file \texttt{texworks-config.txt} in the \textit{configuration} folder of the \TeXworks resources folder. You could add some if required.

5.7 Changing the configuration

We have seen in section 2 (on page 5) that the first time you use \TeXworks, it creates a resource folder and also that it saves default preferences.

It is possible to define a personal place where one wants the resource folder and the preferences. This can be handy when one wants a portable system (e.g., on an USB stick) or when one wants to easily access the templates or completion folders for modifications.

For this, create a file \texttt{texworks-setup.ini} in the programme folder in which you specify the path to the folder containing the completion, configuration, dictionaries,... folders and the configuration file (\texttt{texworks.ini}); there will be two lines:

\begin{verbatim}
inipath=C:/myfolder/TW_conf/
libpath=C:/myfolder/TW_conf/
\end{verbatim}

\texttt{inipath} for the configuration file and \texttt{libpath} for the necessary folders. Here, \texttt{TW_conf} would replace the resource folder \TeXworks. Note that the referenced folder (here \texttt{TW_conf}) should exist—it will not be created—, and that the / is used even on Windows (instead of the common \).

If one wants to put the resource folder in the programme folder as a subfolder, one can use an instruction like \texttt{inipath=./TW_conf/}; all relative paths are taken to be relative to the \TeXworks programme folder (on Mac OS X, the folder containing the app package is used).

\footnote{The name of the main file is used to list the possible candidates for deletion.}
One can also add a line like

\begin{verbatim}
defaultbinpaths=C:/Program Files/MiKTeX 2.7/miktex/bin
\end{verbatim}

to specify where the programmes of the \TeX\ distribution are located; but this instruction is not yet completely operational, especially under Windows.
6 Advanced use: Scripting

6.1 Introduction to Scripting

All the functions and utilities described so far were built into TExworks by default. While some of them could be configured or customized to a certain extent, they are intended to suit the most common needs of a general audience. However, the TEx world is very large and diverse. In order to enable users to address their special needs—from simply making some text bold to fulfilling special requirements for the next book or scientific paper you want to publish—, the core functionality of TExworks can be extended or modified by the use of scripts.

Scripts are simple text files that you can open, read, or modify in any text editor (including TExworks, of course). They are written in a specific scripting language that is essentially a programming language. At the time of writing, TExworks supports QtScript\(^1\) (built-in), Lua (with a plugin), and Python (with a plugin). To see which scripting languages are available on your system, use the Scripts → Scripting TExworks → About Scripts... menu item.

Writing scripts is beyond the scope of this manual, but is documented elsewhere\(^2\). Here, only the installation and usage of scripts will be discussed.

TExworks distinguishes between two types of scripts: standalone scripts and hook scripts. The primary purpose of standalone scripts is to add new functionality to the program. If you need a new function, such as a command to make the selected text bold, a standalone script is the one to choose. These scripts get an item in the Scripts menu, and you can run them simply by

\(^1\)A scripting language similar to JavaScript provided by Qt.

\(^2\)See, for example, Paul Norman’s page http://twscript.paulanorman.com/docs/index.html.
clicking on that menu item (or by using a keyboard shortcut, if the script provides one).

Hook scripts, on the other hand, are meant to extend existing \TeX\ works functions. They are hooked into the code at specific places, e.g., after the typeset process has finished or after a file was loaded, and can add or modify whatever \TeX\ works is doing. One example for this would be a script that analyses a newly loaded file and sets the spell-checking language based on \texttt{babel} commands found in the document. Thus, hook scripts do not show up in the \texttt{Scripts} menu but are instead run automatically when the \TeX\ works function they modify is used.

You can easily determine which type of script you have by opening the script file. Near the top of the file, you should find a line similar to

\begin{verbatim}
// Type: standalone
\end{verbatim}

Alternatively—once the script is installed—, you can use the dialogue available from \texttt{Scripts}$\rightarrow$\texttt{Scripting TEXworks}$\rightarrow$\texttt{Manage Scripts} to display this information.

\section*{6.2 Installing Scripts}

A word of caution first: do not install scripts from a source you do not trust! Before installing scripts, you should make sure that the file you are about to install indeed does what you expect. Scripts are very powerful—they can do almost everything a normal program can do. So while there are some security precautions built into \TeX\ works, you should still be aware that scripts could potentially harm your computer and cause (among other things) crashes and data loss. In particular, scripts can read, create, and modify arbitrary files on your hard drive.

That said, installing scripts is very simple. Script files are generally installed in \texttt{<resources>/scripts} or subdirectories of it. These subdirectories are shown as submenus of the \texttt{Scripts} menu, so they can be used to group and categorize scripts. This is especially useful if you use many different scripts that would otherwise make the \texttt{Scripts} menu very confusing. One easy way to open the \texttt{scripts} folder is the \texttt{Scripts}$\rightarrow$\texttt{Scripting TEXworks}$\rightarrow$\texttt{Show Scripts Folder} menu item.

Since scripts are usually simple plain-text files, they do not come with fancy installers. To install them, simply copy or decompress (if archived, e.g., in a \texttt{.zip} file) the script file—and any other required files that you may have received—into \texttt{<resources>/scripts} or a subdirectory of it.
After having installed a new script file, \TeX{}works needs to become aware of it. It automatically scans for all scripts during start-up, so you could close all \TeX{}works windows and restart the application. An alternative is provided by the \textit{Scripts}→\textit{Scripting \TeX{}works}→\textit{Reload Script List} menu item which rescans all scripts without otherwise interfering with the program.

You can also disable scripts (or whole directories of scripts) if you want to. This can be useful if you do not need some scripts for some time and do not want them to clutter the \textit{Scripts} menu, but do not want to uninstall them entirely. Or if you want to prevent hook scripts from being run automatically. To do this, open the “Manage Scripts” dialogue with the \textit{Scripts}→\textit{Scripting \TeX{}works}→\textit{Manage Scripts} menu item. Simply uncheck the script you want to disable and it won’t bother you again.

### 6.3 Using Scripts

Using scripts is simple. Hook scripts are used automatically—you don’t need to do anything. Standalone scripts show up in the \textit{Scripts} menu or one of its submenus. If you cannot find a script you are looking for, or if you find a script you do not know the purpose of, you can use the “Manage Scripts” dialogue to get additional information (like the author, a brief description, etc.) about it.

Some scripts need to run other programs on your system. One example would be a script that opens the pdf in the system’s default previewer, e.g., for printing. Since running arbitrary commands can in some situations be particularly dangerous, this functionality is disabled by default. You will notice this when a dialogue pops up informing you of an error in the script, or a similar message is displayed in the status bar. To enable scripts to execute system commands, open the preferences dialogue via the \textit{Edit}→\textit{Preferences}... menu item. There, go to the “Scripts” tab and check the “Allow scripts to run system commands” option. If you want to disable this function again later just uncheck the option. Note that this option applies equally to all scripts—there is currently no way to allow command execution only for some scripts.
In this manual, the authors tried to give an overview over TeXworks and a concise introduction to get you started. TeXworks is constantly evolving and improving, however, so the information presented here will never be complete.

Additional, frequently updated documents are posted in the wiki hosted by Google Code at http://code.google.com/p/texworks/w/list. Particularly noteworthy are the following pages:

**SpellingDictionaries** describes how to obtain and install dictionaries for the spell-checker on various systems.  
http://code.google.com/p/texworks/wiki/SpellingDictionaries

**TipsAndTricks** provides a compilation of useful things to know at a glance, such as the \% !TEX root construct.  
http://code.google.com/p/texworks/wiki/TipsAndTricks

**AdvancedTypesettingTools** lists the configurations for several typesetting tools that are not included in TeXworks by default, such as latexmk or the dvips workflows.  
http://code.google.com/p/texworks/wiki/AdvancedTypesettingTools

If you run into problems with TeXworks, it is advisable to browse the mailing list archives accessible via http://tug.org/pipermail/texworks/. If you use TeXworks regularly or are interested in learning about problems and solutions when using it for some other reason, you can also consider subscribing to the list at http://tug.org/mailman/listinfo/texworks to stay up-to-date. For the occasional post to the mailing list, you can also use the Help→Email to mailing list menu item. Please make sure you replace the default subject by something describing your issue and to include
all information that might help resolving it. That way, you are much more likely to get many helpful replies.

If you find a bug in T\TeXworks or want to suggest a new feature you would like to see in a future version, you should have a look at the issue list at Google Code (http://code.google.com/p/texworks/issues/list). Before posting a new item, please make sure that a similar report or request is not already on the list and that the issue list is indeed the right place, though. If in doubt, please ask on the mailing list first.

Happy T\TeXing!
A.1 Syntax highlighting

Among its many other features, \TeXworks also include syntax highlighting. This means that certain things like \LaTeX commands, environments, or comments are coloured, underlined, or highlighted in some other way. \TeXworks also provides the ability to switch between different highlighting schemes\textsuperscript{1}, and to define your own ones. This is useful if you often work with types of files for which no highlighting scheme is provided by default, or if you want to adjust the highlighting schemes to better match your system’s colour scheme.

To modify the highlighting schemes, you have to edit the plain-text file `<resources>/configuration/syntax-patterns.txt`. This file can contain any number of individual sections, each defining a single highlighting scheme to be displayed in the menu structure of \TeXworks. To define a section, just write the name enclosed in square brackets on a line of its own. Naturally, these names should not include the ] character. By default, the following two sections are defined:

\begin{verbatim}
[LaTeX]
[ConTeXt]
\end{verbatim}

In addition, you can add comments to the file by starting a line with \#. Empty lines are ignored.

Each section consists of an arbitrary number of styling rules. Each such instruction consists of three parts: a formatting instruction, a spell-check

\textsuperscript{1}Use \textbf{Format→Syntax Coloring} to change the highlighting scheme for the current document, and \textbf{Edit→Preferences...→Editor→Syntax Coloring} to set the default one.
flag, and a regular expression\(^2\) defining what part of a text to match. These parts must all be on the same line, and separated by whitespaces (e.g., spaces or tabstop characters). Take for example the following line from the default LaTeX section:

\begin{verbatim}
red   Y   %.*
\end{verbatim}

The first part, \texttt{red}, defines the format (in this case, a red foreground colour is specified). The second part, \texttt{Y}, defines that spellchecking should be enabled for text that matches this particular rule. Sometimes, it is useful to put \texttt{N} here to disable spellchecking. For example, if spellchecking would be enabled for \LaTeX{} commands, most documents would be flooded with red underlines indicating misspelled words when in fact they are only special commands. Finally, the third part specifies that this rule should be applied to all text preceded by \%.

Let us take a closer look at the three parts of each rule. In its most general form, the first part—the format instruction—looks like

\begin{verbatim}<foreground_colour>/<background_colour>;<fontflags>
\end{verbatim}

The \texttt{<fontflags>} can be specified independent of the colours (note, though, that it must always be preceded by a \texttt{;}). The background colour (together with the /) can be omitted, but if you specify it, you also have to specify the foreground colour.

Each colour can either be specified by an SVG name\(^3\) or by a hexadecimal value (\#rrggbb\(^4\)) similar as in web documents. The \texttt{<fontflags>} can be any combination of the letter B (bold), I (italic), and U (underlined).

Examples of valid formatting instructions are:

\begin{verbatim}
red
white/#000000
;B
blue;I
#000000/#ffff00;U
\end{verbatim}

\(^2\)For some details on regular expressions, see B
\(^3\)See http://www.w3.org/TR/SVG/types.html#ColorKeywords for a list of valid names.
\(^4\)Because \# is also used to mark comments if given as the first character of a line, you need to add a space, tab, or similar before specifying a hexadecimal foreground color.
A.2 Keyboard shortcuts

The use of keyboard shortcuts greatly facilitates typing in and the management of the source and the preview windows. Their use is much more effective than the use of buttons for frequently-used actions.

Below, you’ll find the shortcuts for source and preview windows. Note that on Mac OS X, Ctrl actually refers to the Command key, which is the usual modifier for keyboard shortcuts. Although the keyboard shortcuts are specified with Ctrl, this will appear as the Command-key symbol in menus. (To refer to the actual Control key on the Mac, the shortcut file should use the name Meta).

Note that the shortcuts listed below are the default shortcuts for the English interface of \TeX\ works. Different languages may use different shortcuts.

All the shortcuts can be redefined either to create new shortcuts or to modify the existing ones to match personal uses or change shortcuts not adapted to one particular keyboard layout. The list of possible actions to associate with shortcuts is given after the predefined shortcuts.

To define your own shortcuts, put a file named shortcuts.ini in the <resources>/configuration folder, next to auto-indent-patterns.txt, delimiter-pairs.txt, ..., texworks-config.txt.

For example, this file could contain:

```
actionHard_Wrap = Shift+F3
actionLast_Page = Ctrl+End
actionFirst_Page = Ctrl+Home
actionWrap_Lines = F3
actionLine_Numbers = F4
actionBalance_Delimiters = F9
```

The first line defines that using \texttt{Shift} ⌘ F3 should open the hardwrap dialogue box in the source window; the second (\texttt{Ctrl} ⌘ End) should bring you to the last page and \texttt{Ctrl} Home (third line) should take you to the first page; with \texttt{F3}, you want to wrap/unwrap lines in the source, with \texttt{F4}, you will show/hide line numbers and with \texttt{F9}, you intend to select the text between corresponding delimiters in the source.
A.2.1 Predefined shortcuts

For working in the source window:

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+’</td>
<td>Go to Preview</td>
</tr>
<tr>
<td>Ctrl+=</td>
<td>Show Selection</td>
</tr>
<tr>
<td>Ctrl+A</td>
<td>Select All</td>
</tr>
<tr>
<td>Ctrl+Alt+S</td>
<td>Save All</td>
</tr>
<tr>
<td>Ctrl+B</td>
<td>Balance Delimiters</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>Copy to Find</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Find...</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Find Again</td>
</tr>
<tr>
<td>Ctrl+H</td>
<td>Find Selection</td>
</tr>
<tr>
<td>Ctrl+L</td>
<td>Go to Line...</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>New</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>Open...</td>
</tr>
<tr>
<td>Ctrl+Q</td>
<td>Quit TeXworks</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Replace...</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>Save</td>
</tr>
<tr>
<td>Ctrl+Shift+E</td>
<td>Copy to Replace</td>
</tr>
<tr>
<td>Ctrl+Shift+N</td>
<td>New from Template...</td>
</tr>
<tr>
<td>Ctrl+Shift+R</td>
<td>Replace Again</td>
</tr>
<tr>
<td>Ctrl+Shift+S</td>
<td>Save As...</td>
</tr>
<tr>
<td>Ctrl+Shift+Z</td>
<td>Redo</td>
</tr>
<tr>
<td>Ctrl+Shift+[</td>
<td>Uncomment</td>
</tr>
<tr>
<td>Ctrl+Shift+]</td>
<td>Comment</td>
</tr>
<tr>
<td>Ctrl+T</td>
<td>Typeset</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>Close</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Ctrl+[</td>
<td>Unindent</td>
</tr>
<tr>
<td>Ctrl+\</td>
<td>Hide Output Panel</td>
</tr>
<tr>
<td>Ctrl+]</td>
<td>Indent</td>
</tr>
</tbody>
</table>
Moving the cursor (hold \texttt{Shift} to select):

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>\rightarrow</td>
<td>1 character right</td>
</tr>
<tr>
<td>Ctrl+\rightarrow</td>
<td>1 word right</td>
</tr>
<tr>
<td>\leftarrow</td>
<td>1 character left</td>
</tr>
<tr>
<td>Ctrl+\leftarrow</td>
<td>1 word left</td>
</tr>
<tr>
<td>\uparrow</td>
<td>1 line up</td>
</tr>
<tr>
<td>\downarrow</td>
<td>1 line down</td>
</tr>
<tr>
<td>PgUp</td>
<td>1 screen up</td>
</tr>
<tr>
<td>PgDown</td>
<td>1 screen down</td>
</tr>
<tr>
<td>Home</td>
<td>Begin of line</td>
</tr>
<tr>
<td>Ctrl+Home</td>
<td>Begin of document</td>
</tr>
<tr>
<td>End</td>
<td>End of line</td>
</tr>
<tr>
<td>Ctrl+End</td>
<td>End of document</td>
</tr>
</tbody>
</table>

For working in the preview window:

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+'</td>
<td>Go to Source</td>
</tr>
<tr>
<td>Ctrl++</td>
<td>Zoom In</td>
</tr>
<tr>
<td>Ctrl+-</td>
<td>Zoom Out</td>
</tr>
<tr>
<td>Ctrl+1</td>
<td>Actual Size</td>
</tr>
<tr>
<td>Ctrl+2</td>
<td>Fit to Width</td>
</tr>
<tr>
<td>Ctrl+3</td>
<td>Fit to Window</td>
</tr>
<tr>
<td>Ctrl+Backspace</td>
<td>Clear</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Find...</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Find Again</td>
</tr>
<tr>
<td>Ctrl+J</td>
<td>Go to Page...</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>New</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>Open...</td>
</tr>
<tr>
<td>Ctrl+Q</td>
<td>Quit TeXworks</td>
</tr>
<tr>
<td>Ctrl+Shift+F</td>
<td>Full Screen</td>
</tr>
<tr>
<td>Ctrl+Shift+N</td>
<td>New from Template...</td>
</tr>
<tr>
<td>Ctrl+Shift+Z</td>
<td>Redo</td>
</tr>
<tr>
<td>Ctrl+T</td>
<td>Typeset</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>Close</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Cut</td>
</tr>
</tbody>
</table>
A. Customizing TeXworks

A.2.2 Actions listed alphabetically

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Z</td>
<td>Undo</td>
</tr>
<tr>
<td>End</td>
<td>Last Page</td>
</tr>
<tr>
<td>Home</td>
<td>First Page</td>
</tr>
<tr>
<td>PgDown</td>
<td>Next Page</td>
</tr>
<tr>
<td>PgUp</td>
<td>Previous Page</td>
</tr>
</tbody>
</table>

- actionAbout_Scripts
- actionAbout_TW
- actionActual_Size
- actionApply_to_Selection
- actionAutoIndent_None
- actionAuto_Follow_Focus
- actionBalance_Delimiters
- actionClear
- actionClose
- actionComment
- actionCopy
- actionCopy_to_Find
- actionCopy_to_Replace
- actionCut
- actionFind
- actionFind_Again
- actionFind_Selection
- actionFirst_Page
- actionFit_to_Width
- actionFit_to_Window
- actionFont
- actionFull_Screen
- actionGoToHomePage
- actionGo_to_Line
- actionGo_to_Page
- actionGo_to_Preview
- actionGo_to_Source
- actionHard_Wrap
- actionIndent
- actionLast_Page
- actionAbout_Scripts
- actionPaste
- actionPlace_on_Left
- actionPlace_on_Right
- actionPreferences
- actionPrevious_Page
- actionQuit_TeXworks
- actionRemove_Aux_Files
- actionReplace
- actionReplace_Again
- actionRevert_to_Saved
- actionSave
- actionSave_All
- actionSave_As
- actionScroll
- actionSelect_All
- actionSelect_Image
- actionSelect_Text
- actionSettings_and_Resources
- actionShow_HideConsole
- actionShow_Scripts_Folder
- actionShow_Selection
- actionSide_by_Side
- actionSmartQuotes_None
- actionStack
- actionSyntaxColoring_None
- actionTile
- actionTo_Lowercase
- actionTo_Uppercase
- actionToggle_Case
A.2.3 Actions listed by menu

For the source window:

<table>
<thead>
<tr>
<th>Menu</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit</strong></td>
<td></td>
</tr>
<tr>
<td>actionBalance_Delimiters</td>
<td>actionRedo</td>
</tr>
<tr>
<td>actionClear</td>
<td>actionSelect_All</td>
</tr>
<tr>
<td>actionCopy</td>
<td>actionTo_Lowercase</td>
</tr>
<tr>
<td>actionCut</td>
<td>actionTo_Uppercase</td>
</tr>
<tr>
<td>actionNone</td>
<td>actionToggle_Case</td>
</tr>
<tr>
<td>actionPaste</td>
<td>actionUndo</td>
</tr>
<tr>
<td>actionPreferences</td>
<td></td>
</tr>
<tr>
<td><strong>File</strong></td>
<td></td>
</tr>
<tr>
<td>actionClose</td>
<td>actionRemove_Aux_Files</td>
</tr>
<tr>
<td>actionNew</td>
<td>actionRevert_to_Saved</td>
</tr>
<tr>
<td>actionNew_from_Template</td>
<td>actionSave</td>
</tr>
<tr>
<td>actionOpen</td>
<td>actionSave_All</td>
</tr>
<tr>
<td>actionOpen_Recent</td>
<td>actionSave_As</td>
</tr>
<tr>
<td>actionQuit_TeXworks</td>
<td></td>
</tr>
<tr>
<td><strong>Format</strong></td>
<td></td>
</tr>
<tr>
<td>actionApply_to_Selection</td>
<td>actionLine_Numbers</td>
</tr>
<tr>
<td>actionAutoIndent_None</td>
<td>actionSmartQuotes_None</td>
</tr>
<tr>
<td>actionComment</td>
<td>actionSyntaxColoring_None</td>
</tr>
<tr>
<td>actionFont</td>
<td>actionUncomment</td>
</tr>
<tr>
<td>actionHard_Wrap</td>
<td>actionUnindent</td>
</tr>
<tr>
<td>actionIndent</td>
<td>actionWrap_Lines</td>
</tr>
<tr>
<td><strong>Help</strong></td>
<td></td>
</tr>
<tr>
<td>actionAbout_TW</td>
<td>actionSettings_and_Resources</td>
</tr>
<tr>
<td>actionGoToHomePage</td>
<td>actionWriteToMailingList</td>
</tr>
</tbody>
</table>
### A. Customizing TeXworks

<table>
<thead>
<tr>
<th>Scripts</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>actionAbout_Scripts</td>
<td>actionShow_Scripts_Folder</td>
</tr>
<tr>
<td>actionManage_Scripts</td>
<td>actionUpdate_Scripts</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Search</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>actionCopy_to_Find</td>
<td>actionGo_to_Line</td>
</tr>
<tr>
<td>actionCopy_to.Replace</td>
<td>actionReplace</td>
</tr>
<tr>
<td>actionFind</td>
<td>actionReplace_Again</td>
</tr>
<tr>
<td>actionFind_Again</td>
<td>actionShow_Selection</td>
</tr>
<tr>
<td>actionFind_Selection</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Typeset</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>actionTypeset</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Window</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>actionAuto_Follow_Focus</td>
<td>actionShow_Hide_Console</td>
</tr>
<tr>
<td>actionGo_to_Preview</td>
<td>actionSide_by_Side</td>
</tr>
<tr>
<td>actionPlace_on_Left</td>
<td>actionStack</td>
</tr>
<tr>
<td>actionPlace_on_Right</td>
<td>actionTile</td>
</tr>
</tbody>
</table>

For the preview window:

<table>
<thead>
<tr>
<th>Edit</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>actionClear</td>
<td>actionPreferences</td>
</tr>
<tr>
<td>actionCopy</td>
<td>actionRedo</td>
</tr>
<tr>
<td>actionCut</td>
<td>actionUndo</td>
</tr>
<tr>
<td>actionPaste</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>File</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>actionClose</td>
<td>actionOpen</td>
</tr>
<tr>
<td>actionNew</td>
<td>actionOpen_Recent</td>
</tr>
<tr>
<td>actionNew_from_Template</td>
<td>actionQuit_TeXworks</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Help</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>actionAbout_TW</td>
<td>actionSettings_and_Resources</td>
</tr>
<tr>
<td>actionGoToHomePage</td>
<td>actionWriteToMailingList</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Scripts</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>actionAbout_Scripts</td>
<td>actionShow_Scripts_Folder</td>
</tr>
<tr>
<td>actionManage_Scripts</td>
<td>actionUpdate_Scripts</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Search</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>actionFind</td>
<td>actionFind_Again</td>
</tr>
</tbody>
</table>
A. Customizing \TeX{}works

<table>
<thead>
<tr>
<th>Typeset</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>actionTypeset</code></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>View</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>actionActual_Size</code></td>
</tr>
<tr>
<td><code>actionFirst_Page</code></td>
</tr>
<tr>
<td><code>actionFit_to_Width</code></td>
</tr>
<tr>
<td><code>actionFit_to_Window</code></td>
</tr>
<tr>
<td><code>actionFull_Screen</code></td>
</tr>
<tr>
<td><code>actionGo_to_Page</code></td>
</tr>
<tr>
<td><code>actionLast_Page</code></td>
</tr>
<tr>
<td><code>actionNext_Page</code></td>
</tr>
<tr>
<td><code>actionPrevious_Page</code></td>
</tr>
<tr>
<td><code>actionZoom_In</code></td>
</tr>
<tr>
<td><code>actionZoom_Out</code></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Window</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>actionGo_to_Source</code></td>
</tr>
<tr>
<td><code>actionPlace_on_Left</code></td>
</tr>
<tr>
<td><code>actionPlace_on_Right</code></td>
</tr>
<tr>
<td><code>actionSide_by_Side</code></td>
</tr>
<tr>
<td><code>actionStack</code></td>
</tr>
<tr>
<td><code>actionTile</code></td>
</tr>
</tbody>
</table>

A.2.4 Other actions

In addition to the static actions listed above, there are also actions for scripts. These are dynamic in nature, as they are created on-the-fly for the available scripts (which may change when you install scripts, remove them, or change some settings). All of these actions are of the form `Script:/uni2423<script_title>`, where `<script_title>` must be replaced appropriately. If you have a script that shows up as My Script, for example, the corresponding action would be named `Script:/uni2423My/uni2423Script`.

A.3 Roots for completion

We give here the keywords for auto-completion as they are supplied by \TeX{}works. They are given in the files `tw-basic.txt`, `tw-context.txt` (initially empty) and `tw-latex.txt` in the `<resource>\completion` folder.

We give them in three columns: the first two show the keywords, the third the (\LaTeX{})\TeX{} code produced. In some cases there is only the code, this means that you can start to enter the (\LaTeX{})\TeX{} code and try to complete it with \[ \].

During completion, the system inserts line feeds and puts the cursor at the first place where one has to enter information to complete the typing. To represent the line feeds we used `\` and `\` for the input point.
So, a line like “\begin{abstract}\it RIR\end{abstract} •” should be interpreted as

\begin{abstract}
\end{abstract} •

with the cursor being position on the central, empty line.

It is possible to see that the keywords have some pattern. The mathematical variables have a keyword starting with \texttt{x}, when they are in a mathematical environment; when they are used alone in the text you add \texttt{d} in front. For example, \texttt{xa} and \texttt{dxa} give \texttt{alpha}, if there is a capital there is a \texttt{c}, as \texttt{xo} for \texttt{omega} and \texttt{xco} for \texttt{Omega}. The keywords for environments start with \texttt{b}: \texttt{bali} for \texttt{\begin{align}}, \texttt{bminp} gives \texttt{\begin{minipage}[]}... while \texttt{bminpo} gives \texttt{\begin{minipage}[][]}...

Keywords defined in \texttt{tw-basic.txt} (defined in \TeX):

\begin{verbatim}
xab \xa \alpha
\xb \xb \beta
\bsk \bigskip
\bigskip\R

\xch \xch \chi
\xd \xd \delta
\xcd \xcd \Delta
\xe \xe \epsilon
\xet \xet \eta
\xg \xg \gamma
\xcg \xcg \Gamma
\hskip
\input

\xio \xio \iota
\xl \xl \lambda
\xcl \xcl \Lambda
\msk \medskip
\medskip\R

\xm \xm \mu
\xn \xn \nu
\end{verbatim}
A. Customizing \TeX\text{works}

\begin{verbatim}
xo \xo \omega
xco \xco \Omega
xcph \xcph \Phi
xph \xph \phi
xp \xp \pi
xcp \xcp \Pi
xcps \xcps \Psi
xps \xps \psi
xr \xr \rho
\text{\scriptsize}
xs \xs \sigma
xcs \xcs \Sigma
\text{\smallskip}
\text{\ssk \smallskip}
xt \xt \tau
tex \tex \TeX
\text{\smallskip}
texs \texs \TeX\text{}\textbackslash{}
\text{\smallskip}
xth \xth \theta
xcth \xcth \Theta
xu \xu \upsilon
xcu \xcu \Upsilon
xve \xve \varepsilon
xvph \xvph \varphi
xvp \xvp \varpi
xvr \xvr \varrho
xvs \xvs \varsigma
xvth \xvth \vartheta
\text{\vskip}
xcx \xcx \Xi
xx \xx \xi
xz \xz \zeta
\end{verbatim}
Keywords defined in \texttt{tw-lateX.txt} (defined in LATEX):

\begin{verbatim}
ncol \ncol &

dd \dd \( I \) •

dxa \dxa \( \alpha \)

dxb \dxb \( \beta \)

dxch \dxch \( \chi \)

dxd \dxl \( \delta \)

dxcd \dxcd \( \Delta \)

dxe \dxe \( \epsilon \)

dxet \dxet \( \eta \)

dxg \dxg \( \gamma \)

dxcg \dxcg \( \Gamma \)

dxi \dxio \( \iota \)

dxio \dxio \( \lambda \)

dxcl \dxcl \( \Lambda \)

dxm \dxm \( \mu \)

dxn \dxn \( \nu \)

dxo \dxo \( \omega \)

dxcph \dxcph \( \Omega \)

dxph \dxph \( \phi \)

dx \dxa \( \pi \)

dxcp \dxcp \( \Pi \)

dcxps \dxcxps \( \Psi \)

dxps \dxps \( \psi \)

dx \dxa \( \rho \)

dxs \dxs \( \sigma \)

dxcs \dxcs \( \Sigma \)

dxt \dxt \( \tau \)

dxth \dxth \( \theta \)

dxcth \dxcth \( \Theta \)

dxu \dxu \( \upsilon \)

dxcu \dxcu \( \Upsilon \)

dxve \dxve \( \varphi \)

dxvph \dxvph \( \varphi \)

dxvp \dxvp \( \varpi \)

dxvr \dxvr \( \varrho \)

dxvs \dxvs \( \varsigma \)

dxvth \dxvth \( \vartheta \)

dx \dxx \( \xi \)
\end{verbatim}
A. Customizing TeXworks

\addtocounter{I}{•}
\adl \addtolength{I}{•} R

\author{I R}
\begin{abstract}
RIR
\end{abstract}

\begin{align*}
RIR
\end{align*}

\begin{alignat*}{I} R\item R\item R\item R
\end{alignat*}

\begin{alignedat}
\end{alignedat}

\begin{align}
RIR
\end{align}

\begin{appendix}
RIR
\end{appendix}

\begin{array}
RIR
\end{array}

\begin{bmatrix}
RIR
\end{bmatrix}

\begin{cases}
RIR
\end{cases}

\begin{center}
RIR
\end{center}

\begin{compactenum}
R
\item
\end{compactenum}

\begin{compactenum}
\item
\end{compactenum}

\begin{enumerate}
\item
\end{enumerate}

\begin{enumerate}
\item
\end{enumerate}

\begin{equation*}
RIR
\end{equation*}

\begin{equation}
RIR
\end{equation}

\begin{figure}
RIR
\end{figure}

\begin{figure}
\item
\end{figure}

\begin{flalign*}
RIR
\end{flalign*}

\begin{flalign}
RIR
\end{flalign}

\begin{flushleft}
RIR
\end{flushleft}

\begin{flushright}
RIR
\end{flushright}

\begin{flushleft}
RIR
\end{flushleft}

\begin{flushright}
RIR
\end{flushright}
A. Customizing TeXworks

\bibitemo \bibitemo \bibitemo \bibitemo \\bibitemo \bibitemo \bibitemo \bibitemo \\bibitemo \bibitemo \bibitemo \bibitemo \\bibitemo \bibitemo \bibitemo \bibitemo \\bibstyle \bibliographystyle{I} \\biblio \bibliography{I} \\
\bottomrule \\bottomrule \\bottomrule \\bottomrule \\bottomrule \\
\boxed{I} \\
caption{I} \\
\cdots \\
\centering \\
\chapter{I} \\
\citep{I} \\
\citet{I} \\
\cite{I} \\
\cline{I} \\
\cmidrule(•){•} \\
\cmidrule(•){•} \\
\cmidrule(•){•} \\
\cmidrule\[I\](•){•} \\
\date{I} \\
\dddddot{I} \\
\dddot{I} \\
\ddots \\
\ddot{I} \\
\documentclass{I} \\
\documentclass{I} \\
\dots \\
\dotsb \\
\dotsc \\
\dotsi \\
\dotsm \\
\dotso \\
\em \\
\em \\emph{I} \\
\emph{I} \\
\end{I} \\
\end{I} \\
\emph{I} \\
\emph{I} \\
\end{I}
\eqref{I}
\fboxrule{I}
\fboxsep{I}
fbox \fbox{I}
\fbox{I}
\footnotesize
foot \footnote{I}
\footnote{I}
fract \frac{I}{•}
\frac{I}{•}
fboxoo \fboxoo \framebox[\vphantom{I}][\;][\;]{•}
\framebox[\vphantom{I}][\;][\;]{•}
\framebox[\vphantom{I}][\;][\;]{•}
\framebox[\vphantom{I}][\;][\;]{•}
\framebox[\vphantom{I}][\;][\;]{•}
fboxo \fboxo \framebox[\vphantom{I}]{•}
\framebox[\vphantom{I}]{•}
\framebox[\vphantom{I}]{•}
\framebox[\vphantom{I}]{•}
\framebox[\vphantom{I}]{•}
geometry \geometry{•}
\geometry{•}
\headwidth
\headwidth
\hline
href \href{I}{•}
\href{I}{•}
\hspace*{I}
\hspace{I}
inco \includegraphics[\vphantom{I}][\;][\;]{R}
\includegraphics[\vphantom{I}][\;][\;]{R}
\includegraphics[\vphantom{I}]{R}
in\includegraphics[\vphantom{I}]{R}
\include\{I\}R
\intertext{I}
\itemRI
ito \item{I}R•
\item{I}R•
itd \itshape
\itshape
lbl \lbl
\label{I}
\label{I}
\Large
\large
\LaTeX
latex \LaTeX
\LaTeX
latexs \latexs \LaTeX\ 
\LaTeXe
latexe \latexe \LaTeXe
latexes \latexes \LaTeXe\\
\ldots
\listoffigures
\listf\listoffigures\R
\listt\listoftables\R
mboxoo \mboxoo \makebox[I][•]{•}
\makebox[I][•]{•}
\makebox[I][•]{•}
mboxo \mboxo \makebox[I]{•}
mpar \mpar \marginpar[I]
\marginpar[I]
\mathbf{I}
\mbf\mathbf{I}
\mcal\mathcal{I}
\mathit{I}
\mit\mathit{I}
\mathnormal{I}
\mrm\mathnormal{I}
\mathsf{I}
\mtt\mathtt{I}
\mbox\makebox{I}
\mdseries
\mdd\mdseries
\midrule
\midr\midrule
\multc\multicolumn{I}{•}{•}
\multicolumn{I}{•}{•}
\multicolumn{I}{•}{•}
\newcolumntype{I}{•}
\newct\newcolumntype{I}{•}
A. Customizing \TeXworks\n
\paragraph{I} R\par \paragraph{I} R

\parboxo \parboxo \parboxo \parboxo \parboxo \parboxo

\paragraph{I} {•} {•}

\parboxo \parboxo \parboxo \parboxo \parboxo \parboxo

\parboxo \parboxo \parboxo \parboxo

\pboxo \pboxo \pboxo \pboxo

\pboxo \pboxo \pboxo \pboxo

\rboxo \rboxo \rboxo \rboxo \rboxo \rboxo

\rboxo \rboxo \rboxo \rboxo \rboxo \rboxo

\rbox \rbox \rbox \rbox \rbox \rbox

\ref \ref \ref \ref \ref \ref

\rnewcoo \rnewcoo \rnewcoo \rnewcoo \rnewcoo \rnewcoo

\rcmoo \rcmoo \rcmoo \rcmoo \rcmoo \rcmoo

\rnewco \rnewco \rnewco \rnewco \rnewco \rnewco

\rcmo \rcmo \rcmo \rcmo \rcmo \rcmo

\rcm \rcm \rcm \rcm \rcm \rcm

\rnewc \rnewc \rnewc \rnewc \rnewc \rnewc

\rncm \rncm \rncm \rncm \rncm \rncm

\rnewc \rnewc \rnewc \rnewc \rnewc \rnewc

\rmfamily \rmfamily \rmfamily \rmfamily

\ruleo \ruleo \ruleo \ruleo \ruleo \ruleo

\scshape \scshape \scshape \scshape \scshape \scshape

\secso \secso \secso \secso \secso \secso

\sectiono \sectiono \sectiono \sectiono \sectiono \sectiono

\setlength \setlength \setlength \setlength \setlength \setlength
A. Customizing \TeXworks

\sffamily \texttt{sfd}
\sffamily \texttt{slshape}
\sffamily \texttt{sqrt}
\sffamily \texttt{stcount}
\sffamily \texttt{spars}
\sffamily \texttt{sparo}
\sffamily \texttt{spar}
\sffamily \texttt{ssecs}
\sffamily \texttt{sseco}
\sffamily \texttt{ssec}
\sffamily \texttt{sssecs}
\sffamily \texttt{ssseco}
\sffamily \texttt{sssec}
\sffamily \texttt{toc}
\sffamily \texttt{tableofcontents}
\sffamily \texttt{tilde}
\sffamily \texttt{bf}
\sffamily \texttt{—}
\sffamily \texttt{it}
\sffamily \texttt{sc}
\sffamily \texttt{sf}
{compactenum}\[ \item \end{compactenum} •
{compactitem}\[ \item \end{compactitem} •
{compactitem}\[ \item \end{compactitem} •
{description}\[ \item \end{description} •
{document}\[ \item \end{document} •
{enumerate}\[ \item \end{enumerate} •
{enumerate}\[ \item \end{enumerate} •
{eqnarray*}\[ \end{eqnarray*} •
{eqnarray}\[ \end{eqnarray} •
{equation}\[ \end{equation} •
{figure}\[ \end{figure} •
{figure}\[ \end{figure} •
{flalign}\[ \end{flalign} •
{flushleft}\[ \end{flushleft} •
{flushright}\[ \end{flushright} •
{gather}\[ \end{gather} •
{gathered}\[ \end{gathered} •
{gather}\[ \end{gather} •
{itemize}\[ \item \end{itemize} •
{itemize}\[ \item \end{itemize} •
{letter}\[ \end{letter} •
{list}\[ \end{list} •
{minipage}\[ \end{minipage} •
{minipage}\[ \end{minipage} •
{multline}\[ \end{multline} •
{multline} •
{picture}\[ \end{picture} •
{pmatrix}\[ \end{pmatrix} •
{quotation}\[ \end{quotation} •
{quote}\[ \end{quote} •
{split}\[ \end{split} •
{subequations}\[ \end{subequations} •
{tabbing}\[ \end{tabbing} •
{table}\[ \end{table} •
{table}\[ \end{table} •
{tabular}\[ \end{tabular} •
{tabular}\[ \end{tabular} •
{tabularx}\[ \end{tabularx} •
There are also environment codes (above) without \begin{ (which is itself a keyword); this allows to finish the environment name alone by if one started to input it manually.
As Ti\TeX works is built on Qt4, the available regular expressions—which are often referred to as regexp—are a subset of those found in Qt4. See the site of Qt4\(^1\) for more information. It is possible to find other information about regexps on the net\(^2\) or from books. But pay attention that not all systems (programming languages, editors, \ldots) use the same set of instructions; there is no “standard set”, unfortunately.

### B.1 Introduction

When searching and replacing, one has to define the text to be found. This can be the text itself (e.g., “Abracadabra”), but often it is necessary to define the strings in a more generic and powerful way to avoid repeating the same operation many times with only small changes from one time to the next; if, for example, one wants to replace sequences of the letter a by ones of the letter o, but only those sequences of 3, 4, 5, 6 or 7 a; this would require repeating (and slightly adjusting) the find and replace procedure 5 times.

Another example: replace all vowels by §—again, this would take 5 replace operations. Here come the regular expressions!

A simple character (a or 9) represents itself. But a set of characters can be defined: \([aeiou]\) will match any vowel, \([abcdef]\) the letters a, b, c, d, e, and f; this last set can be shortened as \([a-f]\) using “-” between the two ends of the range. This can even be combined: \([a-zA-Z0-9]\) will match all letters and all numbers.

\(^1\)http://doc.trolltech.com/4.4/qregexp.html#details—this section is based on the information provided there

\(^2\)see, for example, Wikipedia
To define a complementary set\textsuperscript{3}, one uses “^”: the caret negates the character set if it occurs at the beginning, i.e., immediately after the opening square bracket. \[^{\text{abc}}\] matches anything except a, b, c.

\section*{B.2 Codes to represent special sets}

When using regexps, one very often has to create a search expression which represents other strings in a generic way. If you are looking for a string that matches email addresses, for example, the letters and symbols will vary; still, you could search for any string which corresponds to the structure of an email address (\texttt{<text>@<text>.<text>}, roughly). To facilitate this, there are abbreviations to represent letters, figures, symbols, …

These codes replace and facilitate the definition of sets; for example, to instead of manually defining the set of digits \[0-9\], one can use “\textbackslash d”. The following table lists the replacement codes.\textsuperscript{4}

\textsuperscript{3}A set of characters that are not allowed to occur for this regular expression to match the text
\textsuperscript{4}simplified from Qt4 at trolltech, see note 1
B. Regular expressions

<table>
<thead>
<tr>
<th>Element</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>c</td>
<td>Any character represents itself unless it has a special regexp meaning. Thus c matches the character c.</td>
</tr>
</tbody>
</table>
| \c      | A special character that follows a backslash matches the character itself except where mentioned below. For example, if you wished to match a literal caret at the beginning of a string you would write “\^”.
| \n      | This matches the ASCII line feed character (LF, Unix newline, used in \TeX works). |
| \r      | This matches the ASCII carriage return character (CR). |
| \t      | This matches the ASCII horizontal tab character (HT). |
| \v      | This matches the ASCII vertical tab character (VT; almost never used). |
| \xhhhh  | This matches the Unicode character corresponding to the hexadecimal number hhhh (between 0x0000 and 0xFFFF). \0ooo (i.e., zero-ooo) matches the ASCII/Latin-1 character corresponding to the octal number ooo (between 0 and 0377). |
| . (dot) | This matches any character (including newline). So if you want to match the dot character itself, you have to escape it with “\.”. |
| \d      | This matches a digit. |
| \D      | This matches a non-digit. |
| \s      | This matches a white space. |
| \S      | This matches a non-white space. |
| \w      | This matches a word character or “_”). |
| \W      | This matches a non-word character. |
| \1, ... | The n-th back-reference, e.g. \1, \2, etc.; used in the replacement string with capturing patterns—see below |

Using these abbreviations is better than describing the set, because the abbreviations remain valid in different alphabets.

Pay attention that the end of line is often taken as a white space. Under \TeX works the end of line is referred to by “\n”.

B.3 Repetition

One doesn’t work only on single letters, digits, symbols; most of the time, these are repeated (e.g., a number is a repetition of digits and symbols—in the right order).
To show the number of repetitions, one uses a so-called “quantifier”: \(a^{1,1}\) means at least one and only one \(a\), \(a^{3,7}\) means between at least 3 and at most 7 \(a\); \(\{1,1\}\) is redundant, of course, so \(a^{1,1} = a\).

This can be combined with the set notation: \([0-9]\{1,2\}\) will correspond to at least one digit and at most two, the integer numbers between 0 and 99. But this will match any group of 1 or 2 digits within any arbitrary string (which may have a lot of text before and after the integer); if we want this to match only if the whole string consists entirely of 1 or 2 digits (without any other characters preceding or following them), we can rewrite the regular expression to read \(^*[0-9]\{1,2\}$\); here, the ^ specifies that any match must start at the first character of the string, while the $ says that any matching substring must end at the last character of the string, so the string can only be comprised of one or two digits (^ and $ are so-called “assertions” —more on them later).

Here is a table of quantifiers.\(^5\) E represents an arbitrary expression (letter, abbreviation, set).

<table>
<thead>
<tr>
<th>Quantifier</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>E{n,m}</td>
<td>Matches at least (n) occurrences of the expression and at most (m) occurrences of the expression.</td>
</tr>
<tr>
<td>E{n}</td>
<td>Matches exactly (n) occurrences of the expression. This is the same as (E{n,n}) or as repeating the expression (n) times.</td>
</tr>
<tr>
<td>E{n,}</td>
<td>Matches at least (n) occurrences of the expression.</td>
</tr>
<tr>
<td>E{,m}</td>
<td>Matches at most (m) occurrences of the expression.</td>
</tr>
<tr>
<td>E?</td>
<td>Matches zero or one occurrence of (E). This quantifier effectively means the expression is optional (it may be present, but doesn’t have to). It is the same as (E{0,1}).</td>
</tr>
<tr>
<td>E+</td>
<td>Matches one or more occurrences of (E). This is the same as (E{1,}).</td>
</tr>
<tr>
<td>E*</td>
<td>Matches zero or more occurrences of (E). This is the same as (E{0,}). Beware, the * quantifier is often used by mistake instead of the + quantifier. Since it matches zero or more occurrences, it will match even if the expression is not present in the string.</td>
</tr>
</tbody>
</table>

### B.4 Alternatives and assertions

When searching, it is often necessary to search for alternatives, e.g., apple, pear, or cherry, but not pineapple. To separate the alternatives, one uses |: apple|pear|cherry. But this will not prevent to find pineapple, so we have to

\(^5\)simplified from Qt4 at trolltech, see note 1
specify that apple should be standalone, a whole word (as is often called in the search dialog boxes).

To specify that a string should be considered standalone, we specify that it is surrounded by word separators/boundaries (begin/end of sentence, space), like \bapple\b. For our alternatives example we will group them by parentheses and add the boundaries \b(apple|pear|cherry)\b. Apart from \b we have already seen ^ and $ which mark the boundaries of the whole string.

Here a table of the “assertions” which do not correspond to actual characters and will never be part of the result of a search. \(^6\)

<table>
<thead>
<tr>
<th>Assertion</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>^</td>
<td>The caret signifies the beginning of the string. If you wish to match a literal ^, you must escape it by writing ^</td>
</tr>
<tr>
<td>$</td>
<td>The dollar signifies the end of the string. If you wish to match a literal $, you must escape it by writing $</td>
</tr>
<tr>
<td>\b</td>
<td>A word boundary.</td>
</tr>
<tr>
<td>\B</td>
<td>A non-word boundary. This assertion is true wherever \b is false.</td>
</tr>
<tr>
<td>(?=E)</td>
<td>Positive lookahead. This assertion is true if the expression E matches at this point.</td>
</tr>
<tr>
<td>(?!E)</td>
<td>Negative lookahead. This assertion is true if the expression E does not match at this point.</td>
</tr>
</tbody>
</table>

Notice the different meanings of ^ as assertion and as negation inside a character set!

### B.5 Final notes

Using rexexp is very powerful, but also quite dangerous; you could change your text at unseen places and sometimes reverting to the previous situation is not possible entirely. If you immediately see the error, you can try \(\text{Ctrl} + Z\).

Showing how to exploit the full power of regexp would require much more than this extremely short summary; in fact it would require a full manual on its own.

Also note that there are some limits in the implementation of regexps in \TeX\; in particular, the assertions (^ and $) only consider the whole file, and there are no look-behind assertions.

Finally, do not forget to “tick” the regexp option when using them in the Find and Replace dialogs and to un-tick the option when not using regexps.

\(^6\)simplified from Qt4 at trolltech, see note 1
Compiling \TeXworks

A complete guide how to compile \TeXworks is far beyond the scope of this manual. However, most users should find precompiled versions suitable for their system come either with their \TeX distribution or their operating system. If this is not the case, several precompiled versions can also be downloaded from http://code.google.com/p/texworks/downloads/list.

Compiling \TeXworks yourself is only necessary if your system is not (yet) supported, if you want to always have the latest features (and bugs), or generally want to help in improving \TeXworks further. To this end, there are some documents giving detailed instructions to compile \TeXworks on different machines.

http://code.google.com/p/texworks/wiki/Building

http://code.google.com/p/texworks/issues/detail?id=107

http://code.google.com/p/texworks/wiki/BuildingOnWindowsMinGW
Microsoft, Windows, and the Windows logo are registered trademarks of Microsoft Corporation in the United States and other countries.

Apple, Mac, and Mac OS are trademarks of Apple Inc., registered in the U.S. and other countries.

Google is a trademark of Google Inc.

Unless noted otherwise, all icons are either part of TµXworks or part of the Tango Icon Library (http://tango.freedesktop.org/Tango_Icon_Library).


Index

% !TeX
 encoding, 26
 program, 26
 root, 17
 spellcheck, 27

actions
 alphabetically, 41
 by menu, 42

auto-completion, 22
 roots, 44
 tw-basic.txt, 45
 tw-latex.txt, 47

cleaning folder, 28
 aux files, 29

comments, 11

compiling \TeX\mbox{works}, 64

completion, see auto-completion

configuration, 29
 defaultbinpaths, 30
 inipath, 29
 libpath, 29
 texworks-config.txt, 29
 texworks-setup.ini, 29
 texworks.ini, 29

console bar, 13

CTAN, 11

Ctrl+’, 11

Ctrl+T, 10

document
 creation, 10
 previewing, 10
 source, 2
 typesetting, 10

editing
 change case, 21
 comment, 21
 indentation, 27
 line numbers, 21
 redo, 21
 search/replace, 18
 select a block, 22
 tools, 21
 uncomment, 21
 undo, 21

editor, 2

font, 15

encoding, 26

latin1, 25
utf-8, 11, 25
errors, 12
extension .tex, 10

files
  format, 1
folder
  ⟨resources⟩, 7
  .TeXworks, 6
  .config/TUG, 6
  auto-completion, 6
  configuration, 6
dictionaries, 6
  resource, 6
  resource Mac, 7
templates, 6
  TeXworks, 6
  translations, 6

installation, 5
  Linux, 6
  Mac, 7
  Windows, 5
interface, 8

Kew, Jonathan, 3
keyboard shortcuts, 38
  actions, 38
  predefined, 39
  shortcuts.ini, 38
Knuth, Donald E., 1

Lamport, Leslie, 1
log, 10

METAPOST, 2

output panel, 10
  hide, 14

packages, 1, 11
PDF, 2
PostScript, 2
preamble, 11
preferences, 15
preview, 8
preview window, 10
programme
  default, 26
project, 16

regular expressions, 19, 59
  alternatives/assertions, 62
  introduction, 59
  repetition, 61
  sets, 60

scripts, 31
  installing, 32
  managing, 33
  using, 33
  writing, 31
search/replace, see editing
shortcuts, see keyboard shortcuts
source/editor, 8
spell-checking, 17
  .aff files, 18
  .dic files, 18
SyncTeX, 25
syntax highlighting, 36
tags, 28
  structure, 28
  table of contents, 28
template, 16
TeX, 1
  \AMS-\TeX, 1
  Con\TeXt, 1
  \LaTeX, 1, 9
distribution, see \TeX distribution
dvips, 2
LuaTeX, 2
pdftex, 2
XeTeX, 2
\TeX\ distribution, 5
  Linux, 5
  Mac, 5
    MacTeX, 5
  TeX Live, 5
  Windows, 5
    MikTeX, 5
\TeX\works, 2
  parameters, 15
  toolbar, 8
  typeset, 8
  typing cursor, 13
utf-8, see encoding, utf-8
weird characters, see encoding
windows, 28
wrap lines
  automatic, 27
  hard, 27
WYSIWYG, 8
zoom, 28